Redirected Robo Calls

We have a landline that we recently converted to cell service. I hung on to my old iPhone 8 and AT&T mailed me a sim card for the conversion. It’s been working great now for about a year. It has a lot of features that the old land line didn’t have and it’s way cheaper.

The boss and I have iPhone 13s. She gets robo calls all the time. I rarely get them. Maybe once every 2 or 3 months. I attribute that to NEVER giving doctors offices my cell number. Anyway the “home” cell gets it’s fair share of robo calls (i.e. wanting to buy our house, selling me new car warranties, wanting donations for the police and sheriffs, selling us health insurance, telling us we are in trouble with the IRS, wanting donations for the SPCA and the usual BS). All of a sudden in the last week or so I’m getting junk calls and the “home” phone seems quite.

Have I flipped a switch somewhere that opened up this Hell for my formerly private cell? Maybe something like the dreaded SYNC or something else perhaps when I was repairing my Reminders the other day?

Any help will be appreciated. I’m not liking having to answer phone calls. We generally text.

1 Like

@ImAGolfer -

Maybe try shutting off cloud sync for contacts on the 8 and making sure that the settings on the 8 do not refer to your mobile? Or even just use the 8 as a brick, and do not connect it to any cloud functions and sign out of your Apple ID?



First step I’d check:

In your Settings > Phone, do you have “Silence Unknown Callers” on? In Call Blocking & Identification, do you have “Silence Junk Callers” on?



Just reading your advice to 38Packard, MataroPete, I don’t have “silence Junk Callers” option on my iPhone 13??? Is that because I also use Hiya on the phone?

1 Like

Maybe it was removed in 13? (I have a 12).

I see:
*Settings > Phone > Call Blocking & Identification [which may be a Hiya issue since this is labeled as Carrier Call Identification]
right below
*Settings > Phone > Silence Unknown Callers.



It’s called “Silence Unknown Callers”, and also “Silence Junk Callers” in the Call Blocking and Identification area of the Phone Settings… I never hear or see anyone that’s not in my Contacts, but I have to add contractors or vendors to my Contacts as needed for various projects…

House wired line, at&t from olden days, I just shut off all the ringers except one, and it’s really low volume, easily ignored…