Watching PC on TV

I just connected my Win10 PC to my TV with an HDMI cable to watch something on my computer on my TV. I’ve done this before plenty of times using a laptop, but with my desktop PC something odd is happening. It shows the desktop background picture but that is all. It doesn’t even have the computer icons on it that are on the PC.
And when I go to other pages on my PC, the TV still just shows the background photo.

Any idea why that would be?

Input source not (or wrongly) selected on TV?

Nope. If that were the case, why would the TV be showing the computer’s background photo?

Newer casting / display tech treats the TV as a second monitor. Same thing happens on Youtube on the Mac/Chrome casting to the TV on Airplay. Somehow, need to open up display settings in Win10, choose the TV and take control, or tell your Windows PC program to run the display on the TV.

Your desktop has been extended to the TV. That creates one large combined screen across both the computer monitor and your TV.

You can fiddle with monitor settings (I’ll dig those up if you need it) or you can simply drag the window off the edge of your computer monitor to the TV. No telling whether the TV is connected to the right or left side of your computer monitor, but it will be one of them.



Peter put you on the right track.

Right-click on the background and choose Display Settings. There you can control which screen is your main screen, swap them right-for-left, other useful stuff.

(I live with my laptop connected to a Kensington dock that is, in turn, connected to an ultra-wide monitor. I rarely open anything on the smaller laptop screen, I work on the monitor. Everything else is connected to the dock too; speakers, keyboard, ethernet, label printer, external drives, whatever. The only connection to the laptop is the USB-C cable from the doc, which provides all the power for the laptop as well as a data connection. When I take it to travel I have just that one cable to unplug. The power adapter that came with it lives in the bag I carry it in, I can’t forget it at home.)


Thanks for the tip. But now when I go to multiple displays and choose “show only on 1”, it shows up on my TV, but it’s just the “PC settings” page is what shows up. I don’t want to watch that page on my TV, LOL! When I do that, my PC screen goes black so I can’t use it to go to another website, the one I want to watch.
I hope I’m making sense.
So, now what?

Wait! I figured it out!
I have to choose “duplicate these displays”!
Thanks, guys. I think I’m all set :smile: Thanks to you.