iPad Air 2 to iPad Pro upgrade saga, cont

[ Warning: long rant follows ]

Well, after a week of calls to Apple and trying various things, I still have not been able to successfully restore my new iPad Pro from my old iPad Air:

1 - “quick transfer” of old to new over Wifi gets a transfer error after seeming to copy most of it.

2 - restore of iPad Pro from last (very recent) iPad Air backup on iCloud failed, or should I say, got stuck with 5 GB remaining, and repeated power off/power on actions have allowed it to transfer more data, but it finally got stuck with 700 MB remaining, and nothing gets it past that.

3 - I can’t even backup the old iPad Air to my Windows PC using iTunes. I didn’t want to go down that path, but had no choice. Using Windows 10, most recent iTunes release, Apple branded lightning to UCB-C cable, but the backup always fails after transferring about 11.4 GB with an unspecific “error reading or writing to iPad”.

4 - Interestingly, I CAN use iTunes to back up the iPad Pro, missing data and all.

Apple says it’s impossible to have multiple iCloud backups of the same device, which I think is idiotic, since it wouldn’t cost Apple anything and in fact might make people pay for more iCloud storage. My thought was to rename the old backup of the Air - which is probably corrupt, but at least it exists - and try to do another full backup to iCloud. Of course, I could delete the old backup and try to create another one, but I suspect if even an iTunes backup to a PC fails, then an iCloud backup will too, and then I will be left with not backup at all.

So at this point my options would seem to be:

1 - have some “genius” at an Apple store make a successful iCloud or local PC backup of the Air, perhaps by being able to correct whatever is wrong with the Air that’s prevent it.

2 - somehow sync my Books from the Air to the Pro, since it appears that only the Books app is missing files. The majority of them are there, but about 150 aren’t - all PDFs - and it’s difficult to even figure out which ones are missing.

I’ve read online that there are various ways of doing that sync of Books between devices, and one even uses iTunes, but that seems to depend on there being a successful backup of the Air, which I don’t have. I even tried Airdrop to transfer one of the missing books, but, unbelievably and idiotically, it transferred it with a name of “untitled 9” instead of the name I had given it, which makes it highly unsatisfactory for mass transfers. Plus, I’d still have to be able to determine exactly what books are missing, which is also difficult.

I did find one odd thing with the Notes app on the iPad Pro. All my locally stored notes - over 7000 of them - seem to be there, and I can see the 3 test notes I created in iCloud, but one of them has an embedded PDF which I can’t see: the title of it is there, and so is the size, but the file is somehow corrupt and I can’t even save it to Files for examination. The same iCloud note when viewed on the iPad Air still looks fine. Is the embedded PDF not also in iCloud storage and instead only locally on the Air? That would be a pretty stupid design if true. But I can create a new iCloud note on the Pro with an embedded PDF and it is immediately visible, PDF and all, on the Air.

Well, crraapppp… I’ve not been down that road before, but I surely see how frustrating it is…

Not sure this is any help, it doesn’t mention the Books App, but might be of some interest to even quiz the author if it might apply… I came to this after Googleing your first sentence, well, the 2nd half…

As I understand it, you do have a New iPad, the other thread I was led to believe it was an older iPad… New products give you access to Apple’s support, surely that would include this initial transfer… And it should be escalated to whatever level it takes to get it resolved. Jim sure they have internal tools to see what is wrong, and resolve it… Seems to be a solid fault, there may be a way to bypass a corrupted file…

1 Like

And, just for further digging:


Thanks. I had actually looked at MobileTrans a year ago for some other purpose, but it proved unsatisfactory for reasons I can’t now remember. I’ll have to look into it again.

As for what Apple should be able to do, I agree that SOMEONE at Apple would certainly know how to look at what it is about the old Air that is causing the backups to fail, and then they SHOULD be able to fix it. The iPad is running a version of UNIX after all, and someone with the right software tools SHOULD be able to diagnose and provide a remedy. But do any of those people work at Apple stores? I have been pretty unimpressed with the knowledge of the Apple people manning the support line. But perhaps I’ve only been speaking to the “level 1” people, and really need a “level 3” person.

Oh, another possible solution I was considering might be to offload all the books in the Books app on the old Air to iCloud storage, where they SHOULD be immediately accessible to the new Pro. But it’s possible that that process might fail or hang up as well. But will simply turning on iCloud for the Books app actually migrate all current locally stored books, or does it only ensure NEW books will be stored in iCloud?

Finally, when I connect the old Air to iTunes, I can see all the books in a list just fine, so at least they all seem to be there. I’d really like to be able to use iTunes to just make a backup of the books to the PC and then restore them alone to the new iPad, but from what I can see, there is only the option to do a full backup of everything…which, of course, is what’s failing!

1 Like

That link doesn’t return any search results, and I have no idea what “Yelliot” is!

Well, we’ve been catching up to the Dexter series on Showtime, and in a recent show, one of the whizkid interns went to Elliot rather than Google for a search for info. So, curios me Googled Elliot, and it turns out to be a gathering of search engines, so maybe finds things a little differently than Google alone. Along the way, there’s been a name change to Yelliot, so it seems to be a work in progress…

That’s all I know, it may have more features I haven’t had time to look into, but just another possibility…

Yes, our OS, iOS is built around Unix, also at much, much deeper levels than I’ve explored. In our WeCo/Lucent telecom switches tons of Unix, and chasing hardware & software bugs, led me into delving into the code behind diagnostics to see what notes the developers left to help understand what was failing to be ‘seen’ to pass the section of the diagnostic. So there are clues, if one has the tools to look deeper, but I’m sure they are well protected from us hobbyists, and even lower levels of support. A ton of things are happening behind that curtain, on a Mac, it’s Console and Activity Monitorand Terminal let us see some of it, more, if we knew more… On my system, old, not the latest, I can see the messaging within, for my Mac, the iPhones, Watches, and the old iPad mini 2, some information can be searched, maybe give clues to errors it spots, but rarely useful, other than my curiosity… I chased a ‘wake from sleep’ error for a long time, eventually talked to an Apple engineer, but we never found a hard reason, later OS updates cleared the problem, never knew what that bug was…

Anyway, as it’s a new iPad, you should be helped to find the answers, local guys may not have the experience, but they should be able to escalate it to those that do…

Still not getting any results with Yelliot, just errors. Oh well. I’ll call Apple again tomorrow, and ask for an escalation of the problem if I still get no answer. Ideally, I’d like a new backup of the old Air to work, either to iCloud or to my PC, and then be able to use that to update the new Pro. As you said, it’s a new - expensive! - device I just bought, and I expect a solution!

1 Like