Disk space usage

This evening, the 4 TB SSD on which I usually store my user directory and lots of iTunes movie downloads, among other things, suddenly showed <30 GB of free space. I didn’t think I was even close to filling the space.

However, when I try to do an accounting of the actual used disk space – using Get Info and Calculate Folder Sizes of my user directory plus other things like root-level Documents, and some other mostly-empty user accounts (e.g. Guest, Shared, neither of which contain much) – I find that my user directory takes up the lion’s share of visibly used space at 3.18 TB. I should have almost around 800 GB of space left. When I check my CCC clone of the drive (a 4 TB hard drive), I find there’s 758 GB of available space, which is close enough to what I’m expecting of the SSD.

So, where is that ~800 GB of space on the SSD? What’s filling it? And how can I clear it?

One hint may be in the TV application. When I delete a downloaded file (e.g. a movie) from the TV app, the app asks if I’d like to remove the downloaded file. I clicked yes a few hours ago, some movies were “deleted”, but the empty space counter in Finder didn’t budge. It’s as if the TV application has its own Trash can to hold deleted video files, but I don’t know how to empty that trash, where it is, or even if it really exists.

Any suggestions?



Dead? Try running the Disk Utility app after backing up…

The Captain

1 Like

This built in Windows tool is pretty good and pretty safe. Here are the instructions: 4 Ways to Clear up Unnecessary Files on Your PC - wikiHow

You might consider Ccleaner which will clean up your unnecessary files. It also has a registry cleaner that I have used for many (over 20) years without any problems without backing up what I removed. Its excellent and free.

I have used these without problems. They doesn’t remove critical files without a warning…doc

1 Like

But this board relates to Apple.

1 Like

My bad, I missed that. Thanks…doc

MacOS has integrated some tools to see what is taking up space in the last few versions. Go to System Settings/General/Storage.

To get into the details, I use GrandPerspective, https://grandperspectiv.sourceforge.net/. It gives a nice visual hierarchical view of what’s taking up space. Use the focus buttons to move up and down your folder hierarchy.

1 Like

Also, I have noticed that the “available” space in the bar at the bottom of the finder doesn’t always update when I delete stuff.

I’ve noticed that, too. I think it may be related to having really big drives nowadays and that maybe that “available” counter doesn’t get updated quickly.

I tried using Disk Utility, as the Captain suggested, but that didn’t free up space. BTW, the SSD is formatted APFS. Unlike the Macintosh HD boot volume, the SSD doesn’t show up as containers. I doubt that’s an issue, since my other SSDs are also APFS and don’t have the storage issue.

Disk Utility did find some errors with CCC snapshots, which I assume it fixed, but it also gave me an idea: Way back, I had a hard drive instead of the SSD that’s the source of my problems. When I switched to the SSD, I cloned the original HD over with CCC. (At least, I think I did. That was a while ago.) Now, normally, when I use CCC to make backups, I turn on SafetyNet, and on my current clone, there’s a big _CCC SafetyNet folder of about 68 GB. There’s no such folder on the SSD, but (1) I think there should be, based on my cloning back, and (2) if it’s big enough, it might go a long way to explaining the missing storage.

Anyone know how I might find such a folder? I tried looking from the command line with “sudo ls -sal” from the root of the SSD, and I ran “sudo du -s” on some of the folders, but nothing hidden and anomalously large pops up yet.

Edit: Speaking of CCC, one way I might resolve the situation – without understanding what’s going on – is to reformat the SSD and then re-clone back from my daily clone. However, that strikes me as pretty drastic, not to mention time-consuming.


Hmm… From Frequently asked questions about the CCC SafetyNet folder | Carbon Copy Cloner | Bombich Software :

The Legacy SafetyNet folder is not used when snapshots are enabled on the destination*

When snapshots are enabled on an APFS-formatted destination volume, CCC will implement the SafetyNet feature using snapshots rather than placing files into a separate folder on the destination. Select your destination volume in CCC’s sidebar to find these SafetyNet snapshots.

So, using Disk Utility and selecting View > Show APFS Snapshots for the SSD shows a lot of snapshots with names like com.bombich.ccc.[hexadecimal blather]. The oldest few show sizes of a few GB up to 243.22 GB, and when I add them up, the ones that show some nonzero size add up to 785 GB. As I sit here, more are coming in on Disk Utility, though, and the new totals add up to over 800 GB, so I don’t think these snapshots are separate but may instead be overlapping hard linked collections of files.

Why are these CCC snapshots being stored on the CCC source drive?

Problem almost solved? How do I clear them out? And would doing so be safe?


I think I’d contact CCC/Bombich and see what their support folks have to say about what needs to stay, what can go… Likely tons of duplication, maybe going back to your spinner HD days… So much goes on under the hood, but those folks seem to really have their act together…

All the best… weco

I’ve always had the best support experiences with Bombich. I sent my query in at 10:52 AM PDT, and I got a response at 11:08 AM PDT.

Basically, it’s safe to delete the snapshots using Disk Utility. It’s also a feature of CCC to have snapshots on source drives, though it’s not recommended for boot drives (or, I guess, in my case, user drives).

There’s also a lot of snapshot Documentation in CCC, including on source drives, under the heading “Leveraging Snapshots on APFS Volumes”.


1 Like